Home » Developer & Programmer » Data Integration » Mapping is missing dblink after upgrade (rdbms 11.2, OWB repos 10.2.0.3 > 11.2.0.1, SLES11 x64)
Mapping is missing dblink after upgrade [message #465258] Tue, 13 July 2010 05:47 Go to next message
hristo
Messages: 258
Registered: May 2007
Senior Member
Hi all,

I have upgraded the OWB repos from 10.2.0.3 to 11.2. After that I deployed the mappings. Some of the mappings which is pointing to a remote database is missing there db links.

This is the warning:

MAP_FORETAG_TO_SRC
Create
Warning
ORA-06550: PACKAGE BODY, line 53, column 4:
PL/SQL: ORA-00942: table or view does not exist


This error is due to that the pl//sql script generated by the mapping dont include a dblink in the SELECT statement:

SELECT ...
 "FORETAG"."VER_NR" "VER_NR"
FROM
 "FORETAG"  "FORETAG";


It should read:

SELECT ...
 "FORETAG"."VER_NR" "VER_NR"
FROM
 "BOOTS"."FORETAG"@"LOC_NGSRC_LOC_NGBOOT" "FORETAG";


It does not help to drop the mapping and redeploy it. It seems that in the mapping, the table have lost its reference to the repository object:OWB_OWNER/NGDALA/NGBOOT/FORETAG

One workaround is to manually use "syncronize" on every table, then genereate and deploy. But this will take for ever! Its many hundreds of mappings.

Any ideas?

Regards
H


Re: Mapping is missing dblink after upgrade [message #472683 is a reply to message #465258] Mon, 23 August 2010 04:27 Go to previous message
hristo
Messages: 258
Registered: May 2007
Senior Member
Hi, all!

By doing an export from our PROD environment for only the mappings and re-imported them into our 11.2 repository, the database links are were they should be. Seems to be a BUG and I have opened up a SR for this.

Regards
H
Previous Topic: OWB 10.1.0.5.0 and Oracle 11g
Next Topic: Locations still 10.2 after export/import to 11.2.0.1
Goto Forum:
  


Current Time: Thu Jun 24 14:19:12 CDT 2021